Step By Step Configuration Cisco VoIP Phone in Cisco Packet Tracer.



Router 1 Configuration

Router#sh running-config
Building configuration...

Current configuration : 2102 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
ip dhcp pool voice
 network 192.168.10.0 255.255.255.0
 default-router 192.168.10.1
 option 150 ip 192.168.10.1
ip dhcp pool data
 network 172.16.0.0 255.255.0.0
 default-router 172.16.0.1
 option 150 ip 172.16.0.1
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/0.10
 encapsulation dot1Q 10
 ip address 192.168.10.1 255.255.255.0
!
interface FastEthernet0/0.20
 encapsulation dot1Q 20
 ip address 172.16.0.1 255.255.0.0
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/2/0
 no ip address
 shutdown
!
interface Serial0/3/0
 ip address 1.1.1.1 255.255.255.252
 clock rate 64000
!
interface Vlan1
 no ip address
 shutdown
!
router eigrp 10
 network 1.0.0.0
 network 192.168.10.0
 network 172.16.0.0
 no auto-summary
!
router rip
!
ip classless
!
!
!
!
!
!
!
dial-peer voice 1 voip
 destination-pattern 2...
 session target ipv4:192.168.20.1
!
dial-peer voice 2 voip
 destination-pattern 3...
 session target ipv4:192.168.30.1
!
dial-peer voice 3 voip
 destination-pattern 4...
 session target ipv4:192.168.40.1
!
telephony-service
 max-ephones 10
 max-dn 10
 ip source-address 192.168.10.1 port 2000
!
ephone-dn 1
 number 1001
!
ephone-dn 2
 number 1002
!
ephone-dn 3
 number 1003
!
ephone-dn 4
 number 1004
!
ephone-dn 5
 number 1005
!
ephone 1
 device-security-mode none
 mac-address 00E0.F9E7.8471
 type 7960
 button 1:1
!
ephone 2
 device-security-mode none
 mac-address 0002.16AC.2B51
 type 7960
 button 1:2
!
ephone 3
 device-security-mode none
 mac-address 000C.859C.C836
 type 7960
 button 1:3
!
ephone 4
 device-security-mode none
 mac-address 0060.2FB3.8AAB
 type 7960
 button 1:4
!
ephone 5
 device-security-mode none
 mac-address 000A.4128.6E31
 type 7960
 button 1:5
!
ephone 6
 device-security-mode none
 mac-address 0001.6389.9B92
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
End

Router 2 Configuration

Router#sh running-config
Building configuration...

Current configuration : 2034 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
ip dhcp pool voice
 network 192.168.20.0 255.255.255.0
 default-router 192.168.20.1
 option 150 ip 192.168.20.1
ip dhcp pool data
 network 172.17.0.0 255.255.0.0
 default-router 172.17.0.1
 option 150 ip 172.17.0.1
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/0.30
 encapsulation dot1Q 30
 ip address 192.168.20.1 255.255.255.0
!
interface FastEthernet0/0.40
 encapsulation dot1Q 40
 ip address 172.17.0.1 255.255.0.0
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/2/0
 ip address 1.1.1.5 255.255.255.252
 clock rate 64000
!
interface Serial0/3/0
 ip address 1.1.1.2 255.255.255.252
!
interface Vlan1
 no ip address
 shutdown
!
router eigrp 10
 network 1.0.0.0
 network 192.168.20.0
 network 172.17.0.0
 no auto-summary
!
ip classless
!
!
!
!
!
!
!
dial-peer voice 4 voip
 destination-pattern 1...
 session target ipv4:192.168.10.1
!
dial-peer voice 5 voip
 destination-pattern 3...
 session target ipv4:192.168.30.1
!
dial-peer voice 6 voip
 destination-pattern 4...
 session target ipv4:192.168.40.1
!
telephony-service
 max-ephones 10
 max-dn 10
 ip source-address 192.168.20.1 port 2000
!
ephone-dn 1
 number 2002
!
ephone-dn 2
 number 2001
!
ephone-dn 3
 number 2003
!
ephone-dn 4
 number 2004
!
ephone-dn 5
 number 2005
!
ephone 1
 device-security-mode none
 mac-address 0030.F25B.092E
 type 7960
 button 1:1
!
ephone 2
 device-security-mode none
 mac-address 00D0.FFC9.232E
 type 7960
 button 1:2
!
ephone 3
 device-security-mode none
 mac-address 00D0.97DE.7B63
 type 7960
 button 1:3
!
ephone 4
 device-security-mode none
 mac-address 00E0.8F74.7B79
 type 7960
 button 1:4
!
ephone 5
 device-security-mode none
 mac-address 0040.0B42.08AE
 type 7960
 button 1:5
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
End

Router 3 Configuration.

Router#sh running-config
Building configuration...

Current configuration : 2034 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
ip dhcp pool voice
 network 192.168.30.0 255.255.255.0
 default-router 192.168.30.1
 option 150 ip 192.168.30.1
ip dhcp pool data
 network 172.18.0.0 255.255.0.0
 default-router 172.18.0.1
 option 150 ip 172.18.0.1
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/0.50
 encapsulation dot1Q 50
 ip address 192.168.30.1 255.255.255.0
!
interface FastEthernet0/0.60
 encapsulation dot1Q 60
 ip address 172.18.0.1 255.255.0.0
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/2/0
 ip address 1.1.1.6 255.255.255.252
!
interface Serial0/3/0
 ip address 1.1.1.9 255.255.255.252
 clock rate 64000
!
interface Vlan1
 no ip address
 shutdown
!
router eigrp 10
 network 1.0.0.0
 network 192.168.30.0
 network 172.18.0.0
 no auto-summary
!
ip classless
!
!
!
!
!
!
!
dial-peer voice 7 voip
 destination-pattern 1...
 session target ipv4:192.168.10.1
!
dial-peer voice 8 voip
 destination-pattern 2...
 session target ipv4:192.168.20.1
!
dial-peer voice 9 voip
 destination-pattern 4...
 session target ipv4:192.168.40.1
!
telephony-service
 max-ephones 10
 max-dn 10
 ip source-address 192.168.30.1 port 2000
!
ephone-dn 1
 number 3003
!
ephone-dn 2
 number 3002
!
ephone-dn 3
 number 3001
!
ephone-dn 4
 number 3004
!
ephone-dn 5
 number 3005
!
ephone 1
 device-security-mode none
 mac-address 0040.0B32.0C22
 type 7960
 button 1:1
!
ephone 2
 device-security-mode none
 mac-address 0040.0B6E.9960
 type 7960
 button 1:2
!
ephone 3
 device-security-mode none
 mac-address 0001.C770.E73D
 type 7960
 button 1:3
!
ephone 4
 device-security-mode none
 mac-address 00D0.97DA.A81A
 type 7960
 button 1:4
!
ephone 5
 device-security-mode none
 mac-address 0060.3E37.BEE7
 type 7960
 button 1:5
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
End

Router 4 Configuration

Router#sh running-config
Building configuration...

Current configuration : 2009 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
ip dhcp pool voice
 network 192.168.40.0 255.255.255.0
 default-router 192.168.40.1
 option 150 ip 192.168.40.1
ip dhcp pool data
 network 172.19.0.0 255.255.0.0
 default-router 172.19.0.1
 option 150 ip 172.19.0.1
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/0.70
 encapsulation dot1Q 70
 ip address 192.168.40.1 255.255.255.0
!
interface FastEthernet0/0.80
 encapsulation dot1Q 80
 ip address 172.19.0.1 255.255.0.0
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/2/0
 no ip address
 shutdown
!
interface Serial0/3/0
 ip address 1.1.1.10 255.255.255.252
!
interface Vlan1
 no ip address
 shutdown
!
router eigrp 10
 network 1.0.0.0
 network 192.168.40.0
 network 172.19.0.0
 no auto-summary
!
ip classless
!
!
!
!
!
!
!
dial-peer voice 10 voip
 destination-pattern 1...
 session target ipv4:192.168.10.1
!
dial-peer voice 11 voip
 destination-pattern 2...
 session target ipv4:192.168.20.1
!
dial-peer voice 12 voip
 destination-pattern 3...
 session target ipv4:192.168.30.1
!
telephony-service
 max-ephones 10
 max-dn 10
 ip source-address 192.168.40.1 port 2000
!
ephone-dn 1
 number 4001
!
ephone-dn 2
 number 4002
!
ephone-dn 3
 number 4003
!
ephone-dn 4
 number 4004
!
ephone-dn 5
 number 4005
!
ephone 1
 device-security-mode none
 mac-address 0001.6489.2450
 type 7960
 button 1:1
!
ephone 2
 device-security-mode none
 mac-address 0010.11DD.29AD
 type 7960
 button 1:2
!
ephone 3
 device-security-mode none
 mac-address 00E0.F98D.6061
 type 7960
 button 1:3
!
ephone 4
 device-security-mode none
 mac-address 0060.7020.3C23
 type 7960
 button 1:4
!
ephone 5
 device-security-mode none
 mac-address 0060.5C52.ABD2
 type 7960
 button 1:5
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end



You can see the different pin code numbers are Connecting.




Please go through this configuration for configure VoIP phone with Cisco Router.
Let me know if any challenge.



Comments

Post a Comment

Popular posts from this blog

How To Setup Social Publishing CMS (Content Managemnet System) Using Pligg in CentOS 6.5

How To Install And Configuring OpenFire XMPP Chat server on centos 6.5